常见问题

产品 / 插件
平台 / 框架

ZEGO 云通讯 SDK 支持哪些平台,各平台对系统版本的要求是什么?

产品 / 插件:实时音视频 / 实时语音 / 低延迟直播 / 畅直播

平台 / 框架:全平台

更新时间:2022-01-18 10:48


ZEGO 云通讯包含如下产品和 SDK:

各 SDK 支持的平台以及各平台对应的系统版本要求如下表:

平台 系统版本要求 Express-Video SDK Express-Audio SDK Low-Latency Live Streaming SDK
iOS
iOS 7.0 或以上版本。

iOS SDK 支持 arm64 架构。

支持
支持
支持
Android
Android 4.4 或以上版本。

Android SDK 支持如下架构:

  • arm64
  • armv7
支持
支持
支持
macOS
macOS 10.10 或以上版本。

macOS SDK 支持 x86_64 架构。

支持
支持
支持
Windows
Windows 7 或以上版本。

Windows SDK 支持如下架构:

  • x86
  • x86_64
支持
支持
支持
Linux
Ubuntu 14.04 或以上版本。
支持
支持
-
Web
支持如下浏览器:

  • Chrome 58 或以上
  • FireFox 56 或以上
  • Safari 11 或以上
  • Opera 45 或以上
  • QQ 浏览器最新版
  • 360 安全浏览器极速模式
  • 微信浏览器
  • WebView

Web 平台的支持情况还与设备型号及系统版本等有关,详情请参考 Web SDK 支持哪些浏览器

支持
支持
支持
微信小程序
微信小程序基础库 1.7.0 或以上版本。
支持
支持
-
Flutter
Flutter 1.12 或以上版本。

Unity SDK 支持如下平台:

  • iOS(arm64)
  • Android(arm64、armv7)
支持
支持
-
Electron
Electron 5.0.8 或以上版本。

Electron SDK 支持如下平台:

  • macOS(x86_64)
  • Windows(x86、x86_64)
支持
支持
-
Unity3D
Unity 2018.4.21f1 或以上版本。

Unity3D SDK 支持如下平台:

  • iOS(arm64)
  • Android(arm64、armv7)
  • macOS(x86_64)
  • Windows(x86、x86_64)
支持
支持
-
Cocos2D
cocos2dx 4.0 或以上版本。

Cocos2D SDK 支持如下平台:

  • macOS(x86_64)
  • Windows(x86、x86_64)
支持
支持
-
React Native
React Native 0.60.0 或以上版本。

React Native SDK 支持如下平台:

  • iOS(arm64)
  • Android(arm64、armv7)
支持
支持
-
uni-app
HBuilderX 3.0.0 或以上版本。

uni-app SDK 支持如下平台:

  • iOS(arm64)
  • Android(arm64、armv7)
支持
支持
-
本篇目录
下载 PDF