常见问题

产品 / 插件
平台 / 框架

如何交叉编译 Linux v4l-utils 依赖库?

产品 / 插件:实时音视频 / 实时语音

平台 / 框架:Linux

更新时间:2022-07-19 15:16

本文将以在 Ubuntu 20.04 系统的 x86_64 机器上,为 aarch64 架构的嵌入式机器,交叉编译 v4l-utils(libv4l)为例,进行介绍。

  1. 安装编译 v4l-utils 所需的依赖库。

    $ apt update
    $ apt install make automake libtool
  2. 安装交叉编译工具链。

    此处示例安装最新版本的 GNU GCC 工具链,请根据实际情况为自己的嵌入式机器安装正确的交叉编译工具链。

    $ apt update
    $ apt install gcc-aarch64-linux-gnu g++-aarch64-linux-gnu
  3. V4l 官网 下载最新版本的 V4l-utils 源码并解压。

    例如下载 v4l-utils-1.22.1.tar.bz2 到本地。

    $ wget https://linuxtv.org/downloads/v4l-utils/v4l-utils-1.22.1.tar.bz2
    $ tar xf v4l-utils-1.22.1.tar.bz2
    $ cd v4l-utils-1.22.1

    然后通过 tar 解压源码,并 cd 进入目录。

    • 若找不到 "wget",可以通过 apt install wget 安装 "wget" 。
    • 若 "tar" 解压失败,可能是系统没有安装 "bzip2" 库,可以通过 apt install bzip2 安装。
  1. 通过 ./configure 生成配置文件。

    您可以通过 官方 INSTALL 文档 了解更多信息。

    $ ./configure --disable-doxygen-doc --without-jpeg --with-pic \
        --host=aarch64-linux-gnu --prefix=/usr/aarch64-linux-gnu
    • 通过 --host 参数指定交叉编译的目标为 aarch64-linux-gnu 。此处需要根据您的实际情况,修改为您的交叉编译目标。
    • 通过 --prefix 参数指定安装路径为 /usr/aarch64-linux-gnu 。此处需要根据您的实际情况,修改为您的交叉编译工具链的安装路径。
  2. 通过 -j 参数指定并发编译的并行任务数量,或直接通过 make 编译。

    $ make -j$(nproc)

    若编译时遇到 "std" 相关错误,有可能是因为你的编译器版本较低,可以尝试通过在执行步骤 4 的 ./configure 前执行 export CXXFLAGS="-std=gnu++11" 指定使用 gnu++11 来编译 C++ 代码。

  3. 通过 make install 安装 v4l-utils 到交叉编译工具链的安装路径,即步骤 4 通过 prefix 参数指定的路径。

    $ make install
本篇目录
下载 PDF